This page last changed on Apr 15, 2013 by sadgamergeek.

After helpful advice in another thread, I've upgraded my controller (running on Raspberry Pi) to 2.1 alpha so I could get my ShellExe sensors working.

The sensors are indeed working fine now, but it seems to have broken something that was fine before. I have three pairs of on/off commands, each linked to a button, that run one shell script with a unique parameter to turn on/off three different LightWaveRF power sockets. The shell script logs each call so I can see when it was called and what parameter was passed to it. After the upgrade, the buttons no longer all switch on/off the correct devices. Some don't call the script at all now, and some call it but with the wrong parameter. This is not reflected in the UI designer though - this still shows each button calling the correct command.

From what I can tell, the controller.xml file looks OK too. It's a shame the UI designer doesn't show the unique ID for each button, as that would make it easier to work out where things are going wrong.

I've kept my old 2.0.1 controller install, so I swapped back to that and synced. All the on / off switches worked as they should again (but not the sensors - seems like I can have one or the other but not both!), so it definitely looks like an issue with 2.1 alpha.

Can anyone suggest how I can try to debug further what is happening?

Richard

Scrub that!

After testing it out on 2.0.1 I've switched back to 2.1 and synced again. That seems to have fixed it.

I'd be interested to know why the linkage was so screwed up the first time, but I guess I'll never know now!

Posted by sadgamergeek at Apr 15, 2013 17:09
Document generated by Confluence on Jun 05, 2016 09:40