This page last changed on Oct 11, 2015 by decan.

I'm testing OpenRemote with a Sonos application. I build a little test panel just with a play and pause button who send the play and pause command to the Sonos Player.
I run Webconsole on a Windows Laptop , every thing works fine the first time , when I click on the button , but te second time nothings happen. In the log file , There is only one command send without error message.
When I close the webconsole and restart again , It's works for one time again.
When I run the same panel with the play and pause button on IPhone , every thing works fine.
What do I wrong ?

Hi Andy,

I have no troubles with my Sonos setup.

How are you passing the commands to the Sonos. I do everything on mine via HTTP eg commands http://192.168.1.15:5005/Glenn/play

Posted by glennl at Oct 15, 2015 10:23

Yes , with commands like this (http:/192.168.0.139:5005/living/play) , But in the webconsole I can send the command only One time. But if I send the commands in webbrowser (Edge) everything works perfect. I expect It must be a setting (or bug) in the webconsole.

Posted by decan at Oct 15, 2015 11:25

What does your controller.xml file say?

Mine goes as follows, I have all similar ones, do play pause various other things no problem

   <command id="1974" protocol="http">
      <property name="method" value="GET" />
      <property name="url" value="http://192.168.1.15:5005/Glenn/play" />
      <property name="name" value="Play" />
    </command>
Posted by glennl at Oct 16, 2015 08:20
Document generated by Confluence on Jun 05, 2016 09:32