This page last changed on Feb 07, 2012 by nthnth.

Hi all,
First, congratulations to the OR team. Great job!
I'm on the way to finalize the design of my interface, mixing knx, http and IR commands
I now meet a strange issue:
After UI saving, controller sync and configuration reload, I'm not able to use a few http commands.
All the unusable commands are located in the same area on the screen.
When I switch to the web console, I can use all the http commands.
I tried many time to reload and resync,
Thanks in advance for your help.

You could try and delete the iPhone app and reinstall. This makes sure that the app is loading all the information from the controller.
Since it works with the web-console, I assume an issue with iOS console.

Posted by mredeker at Feb 08, 2012 07:55

Thanks for the prompt reply.
I already tried. I have the same situation on 2 different iPhones.
I investigated deeper: When I shut down the app, and restart it, the commands work normally.
As soon as I leave the screen, and come back after a navigation on an other screen, the commands aren't accessible anymore. Always exactly the same buttons, let's say roughly the bottom 25% (Portrait)
Even the press image is not displayed while pressing the button.
If I leave the app again, restart it, I can press the buttons. As long as I stay in this screen, it's fine. If I leave to come back, it doesn't work.
Thanks for your support

Posted by nthnth at Feb 08, 2012 08:07

Is this a standard button or a switch ?
Could you send me your configuration (exported zip file) to eric [at] openremote [dot] org?

Posted by ebariaux at Feb 08, 2012 10:22

they're standard buttons.
I'm going to send you the zip file right now.
Thanks,

Posted by nthnth at Feb 08, 2012 10:27

OK, got the config installed, can you tell me what button you're seeing the problem with ?

Posted by ebariaux at Feb 08, 2012 11:05

Of course.
Go to the screen with the living room
Clic on the small remote (left door of the white furniture) (Pieces/Salon)
You will have the panel with the audio video devices displayed (Télécommande / Image Son)
Clic on the Freebox remote, bottom right corner
You obtain a remote (Freebox remote)
All the buttons below the circle are affected by this malfunction.

Posted by nthnth at Feb 08, 2012 11:17

Could not reproduce any issue. I tried on iPhone 4 and with simulator.

Which application are you using from the App Store?
This is the correct version to use : http://itunes.apple.com/be/app/openremote/id407587441?mt=8

Posted by ebariaux at Feb 09, 2012 10:51

Excellent!
I was running the 2.0
The issues disappeared wit the the 2.1. Great!
And once again, thanks for the job done.

Posted by nthnth at Feb 09, 2012 11:13

Glad it did fix the issue.

I know of a few bugs in the 2.1 version (e.g.: application crash if trying to swipe between pages when there is just 1 page, sensor value truncated, issue with authentication on panel level), so don't hesitate to post if you find anything.

A 2.2 version with some fixes will be released, but unless there are blocking issues for anybody, it'll be at least a month from now

Posted by ebariaux at Feb 15, 2012 12:26

I noticed this.
Especially when a left-to-right or right-to-left command is available on a screen, the command is sometimes fully functional, and sometimes the screen (background picture) starts to move left or right. Sometimes the app finally crashes, and sometimes not.
Each time I close the application before the crash, the command is functional again after the restart.

Posted by nthnth at Feb 15, 2012 21:01
Document generated by Confluence on Jun 05, 2016 09:30