This page last changed on Jun 18, 2009 by janbra.

Hi.

Does anybody know if iKNX version 1.1 is supposed to work with the new iPhone 3.0 software (I can´t get it to work)?

Jan

AFAIK, Jörg's been beta testing a new 3.0 version. He will be able to provide more details.

Posted by juha at Jun 18, 2009 16:38

Sorry for the delay...

Version 1.2 of OR KNX is working fine under 3.0 (this is basically the version I showed in Amsterdam). Unfortunately the update process is blocked by some stupid database problem in the App Store. Apple promised to fix that "within the next days". Hopefully this is true and I can finally upload the new release.

Posted by jfalkenberg at Jun 25, 2009 20:59

I have noticed that the name of the application has changed to OR KNX, and that the price has gone up, but it is still listed as version 1.1. Is that correct?

Also, is the free version, iKNX LITE, discontinued?

Jan

Posted by janbra at Jul 07, 2009 19:27

Hello Jan,

Regarding iKNX Lite, it is not discontinued. However, we are in the process of moving it to a new OpenRemote account. It will be available again once that transition is complete. Unfortunately I don't have an ETA on that as dealing with Apple makes things... umm, indeterminate. I'm creating the necessary certificates for Jörg right now, we'll see what happens next.

– Juha

Posted by juha at Jul 07, 2009 22:08

Hello Juha,

I noticed that the commercial version of OR KNX, version 1.2, was uploaded, so I bought that. I have now configured parts of my system, with varying levels of success. Are you interested in more detailed feedback? If so, where would you like me to post it?

Jan

Posted by janbra at Jul 11, 2009 09:45

Hello Jan,

Feedback is very welcome. Please go ahead and post here on the forums.

Thanks,

– Juha

Posted by juha at Jul 12, 2009 12:36

Hello Juha,

Unfortunately, the application has become so unstable, as to render it practically useless. I am using an Ipod Touch, with version 3.0, a Berker/Siemens IP router, and a 3Com WLAN router. I have inserted about 25 groups into OP KNX. That means that quite a few groups are out of view in the Control window. As soon as I try to scroll down, the application quits. I can´t just start the application immediately. It just reports Connection failure. If I leave it alone a few minutes, it can be started again, only to quit again as sonn as I try to scroll.

I really don´t know what to do about this, since I can´t figure out what the problem is.

Any suggestions would be appreciated.

Jan

Posted by janbra at Jul 16, 2009 13:34

Thanks Jan,

I will ping Jörg and see if he has some suggestions. The application quitting sounds like an issue.

– Juha

Posted by juha at Jul 16, 2009 15:02

Hello Jan,

sorry for your problems... I got a crash report from iTunes and had a look at it. Unfortunately it makes no sense at the moment and I cannot reproduce it. As soon as I've a clue what's going on, we will release an update.

Jörg

Posted by jfalkenberg at Jul 16, 2009 17:01

Hello Jörg.

Thank you for the reply. After installing OR KNX on my iPod, it worked as advertised for a while. Although there were a few things that I thought might be bugs (like the fact that a change ina group de facto would not be saved when the save button was pushed, as evidenced by the fact that if the application crashed after saving, all changes since starting the app. the last time would be lost), it was relatively stable. It would regularily crash if the connection to the IP router was lost. After a while it started to become more and more unstable. It would crash every time i tried to scroll in the control window. I tried to delete some of the groups, but to no avail. Now, I can´t even get it to start. It crashes as it tries to connect. After a previous crash, it was not possible to reconnect at once. I had to wait a couple of minutes, or reestablish a new connectin to the IP router. I would just get the message "Connection error, could not connect to"...

So, the application is of no use for me at the moment, which is a pity, as I love the idea. I hope you find a solution to the problem.

Jan

Posted by janbra at Jul 20, 2009 21:40

Dear Jan,

thanks for the explanations. I will concentrate my search for the bug on the control window now.

Is your device jailbroken? Do you have SSH access to your iPod? In this case you could help us by sending your settings. If you would like to help, I can send you detailed instructions how to extract them.

The problem that OR KNX cannot reconnect to the IP gateway is due to the crash. Due to that OR KNX could not disconnect properly from the gateway which as a consequence denies a second (in its eyes) connection from your device. Typically (at least my Siemens N148) needs one or two minutes to delete you connection internally if you no longer react to the keep-alive packets.

Jörg

Posted by jfalkenberg at Jul 21, 2009 06:15

Hello Jörg,

My iPod is not jailbroken. I am afraid I don´t know what SSH access is, but I would be more than happy to help in any way I can.

Jan

Posted by janbra at Jul 21, 2009 12:17

Hello Jörg.

Sorry, I forgot: I can actually get the app to start, if I change from Control to Monitor or Database, before hitting Connect. As soon as I touch the Control tab, the app crashes.

Jan

Posted by janbra at Jul 21, 2009 12:25
Document generated by Confluence on Jun 05, 2016 09:30