This page last changed on May 06, 2014 by dlowet.

I recently tried to add some switches and sensors to my setup.

If I sync my controller I get a lot of error messages like this:
exception.XMLParsingException: Expression '//or:*[@id='133']' matches more than one element : 2

I don't see what is wrong with my configuration. A lot of things don't work anymore after this small update.

What can I do about it?

Hi,

Yes, similar problem here. Most of my switches have stopped working. Scenes and sliders appear to, be working fine...

Davy, have you got any further?

Posted by gheinert at May 12, 2014 23:22

Please send your account details. I don't recall what the fix was but can try to look it up.

Posted by juha at May 12, 2014 23:42

I have send the login details to contact@openremote.org

Thanks for the effort!

Posted by dlowet at May 13, 2014 19:02

Hi Juha,

Thanks for getting back to me.
Tried your suggestion. No luck. The switches have stopped working. Scenes and sliders are working fine. I don't think it is a problem with the KNX Sensors, as if I switch the lights on or off from a normal KNX switch, the status is updated in OpenRemote...

Had still saved a previous controller.xml panel.xml and those work fine. I have looked at one switch more closely. I looked at the controller.xml and panel.xml and the ids of all seem to match up fine. But it turns out that the switch id "240" for this switch is not unique. The id "240" is also used for a KNX command. I have changed the switch id in the controller.xml and panel.xml to "1240" and now this particular switch works.

Thus it appears to be a problem with IDs in the controller.xml not being unique. This may have come to light because my OpenRemote Design is quite large...

Has something changed in the Designer recently in the ways IDs are allocated? As the old controller.xml file has not ID duplication.

I have e-mailed you the IDs for this particular switch as well as the panel.xml and controller.xml (exported from RoseMary).

By the way the ID for this switch is also not unique on the controller.xml file downloaded from the preview designer...

Best wishes

Gideon

Posted by gheinert at May 18, 2014 20:57

Just wanted to let you know that we're looking in to this. Will let you know as soon as we have more info.

Posted by ebariaux at May 20, 2014 18:43

I just wanted to know if it's possible to fix this issue. Can you let us know when you think we can try our new configuration again?

Thanks, Davy

Posted by dlowet at Jun 03, 2014 19:25

I do have a bug fix that should solve this issue.
I need to create the appropriate patch branch to implement it, then we'll merge to a version that can be deployed on-line.
I'll synchronize with Juha. Hopefully somewhere next week that should be OK but can't guarantee it as I have a lot of customer work to deliver next week.

Posted by ebariaux at Jun 05, 2014 15:31

Hi Juha,
Hi Eric,

Thank you very much for looking into this problem. A fix would be fantastic.
Do you already know whether our old Designs are recoverable?? Juha mentioned that he wanted to look whether something could be salvaged from the backups.
My design was quite big and am planning to add the next few rooms to it. Just hoping that I don't have to start from the beginning again...

Best wishes

Gideon

Posted by gheinert at Jun 08, 2014 19:02

Sorry been abroad a lot next week so could not finish on this. Resuming now...

Posted by ebariaux at Jun 14, 2014 19:10

Hi Eric,

Any news yet on the fix about the mismatched IDs?

Best wishes

Gideon

Posted by gheinert at Jul 05, 2014 09:28

Could you already make any progress on this issue?

Best regards,

Davy

Posted by dlowet at Jul 25, 2014 21:10

Sorry guys, I've coded the patch to this several weeks ago but I'm not the one that can deploy it to the server...

Posted by ebariaux at Jul 26, 2014 05:52

Juha,

Is there a chance that you could deploy the patch to the server???

Thanks

Gideon

Posted by gheinert at Jul 31, 2014 21:17

I would really appreciate to have a solution soon for this issue.

Is this bug also present in the professional version?

Posted by dlowet at Aug 27, 2014 19:24

Hi Davy,

I managed to work around the issue by running a local Designer setup and reconstructing the SQL Beehive database manually from my controller.xml and panel.xml. But that was very laborious, tidious and not straightforward. I am now unsing my own, local Designer rather than the Cloud based one. It also means I only have palceholders for my pictures in the Designer (but not in the final design deployed to the controller).

Eric, where can I find the patch?
I have asked Juha to send me a SQL dump of my beehive data, then I could try the patch on my own, local Designer setup...

Best wishes

Gideon

Posted by gheinert at Aug 28, 2014 10:49

Wow, what a lot of work. I don't see it as an option for me. I really don't want to spend that much time for some additional actuators I wanted to add to the project.

I will wait until there is a good solution for this issue.

It's really strange that my project is categorized as a big project, we just have a normal house with only some actuators for the lights and blinds (it's all with KNX). So why are we the only ones which have this issue?

Best regards,

Davy

Posted by dlowet at Aug 28, 2014 19:30

This is the fix branch:
svn+ssh://svn.code.sf.net/p/openremote/code/patches/individual/Designer_2_13_9_ColorpickerAndWebWidget_248-395-333-384-398-437-497-MODELER-537

Depending on which base branch you would merge this into, you need to make sure the other required issues (numbers listed in the branch name) are already present.

Posted by ebariaux at Sep 08, 2014 07:44
Document generated by Confluence on Jun 05, 2016 09:37