This page last changed on Jun 23, 2010 by fabulous.

Where can we find the source code for this app ?

I've find only openremote boss.

Thanks,

Fabrice.

Hello Fabrice,

The iKNX app source is currently not available.

Best regards,

– Juha

Posted by juha at Jun 23, 2010 21:13

Then, can you answer me ?

I'm looking for months, a solution to my problem and nobody wants to help me.

Fabrice.

Posted by fabulous at Jun 24, 2010 06:10

I'm not sure what you expect to find from the source code – your issue sounds like a networking issue between your LAN setup, routers and KNX/IP gateway?

Unfortunately I am unable to help with that

Posted by juha at Jun 24, 2010 09:44

I recall you that it works good remotely to my installation with ETS3.
I expected to find in the source code of how the app accesses the KNX.
In the app, it does not tell any of the two addresses for tunneling, so I thought that these addresses were set by the app in its code (to make an analogy with the functioning of ETS3).

Regards,
Fabrice.

Posted by fabulous at Jun 24, 2010 13:28

So usually the gateway is discovered with a multicast request in the subnet which gives back the addressing information.

Obviously such auto-discovery does not work remotely.

Haven't looked at remote access with iKNX so can't say more about it, obviously static IP configuration needs to be used instead.

Posted by juha at Jun 24, 2010 14:26

I understood for the multicast locally, and indeed it works well.
For remote access, is another matter, the IP address must be either fixed or redirected by a dyndns.

(I already tried the two systems on installations different)
FYI, when I try to connect to my setup with my iPhone 3G mode only, I see the Tx / Rx LED on the router IP / KNX switch on and off. Finally I received a message that tells me a communications error.
So that telegrams arrive until well Router IP / KNX, right?

Fabrice.
Thank you for your interest in my problem Juha.

Posted by fabulous at Jun 24, 2010 14:52

Well it does sound like traffic is going through then but along the way somewhere the communication channel is broken or protocol is incorrectly translated.

Haven't tried remote access so am unable to comment further.

Posted by juha at Jun 24, 2010 15:11

Thank you for your analysis juha,
Can you talk about my problem to Jörg ?
it might know how does it works.
Sincerely,
Fabrice.

Posted by fabulous at Jun 24, 2010 15:38
Document generated by Confluence on Jun 05, 2016 09:31