This page last changed on Jan 03, 2015 by galbip.

Hi,

I'm trying since days to show on the Android UI a news channel live video using WebView but I'm getting just the audio...
On webconsole it works properly...

This is the URL I'd like to display

http://www.rainews.it/dl/rainews/live/ContentItem-3156f2f2-dc70-4953-8e2f-70d7489d4ce9.html

and hereafer my setup:

OpenRemote-Controller-2.1.0_SNAPSHOT-2013-06-17 running on Windows7 with Java 8
Android Console 2.1.1
Android Device is a Nexus7 tablet with Android 4.4.4

Any idea? I'm getting crazy

Thank you

As far as I know it"s not support streaming video

Posted by szejkindudi at Jan 04, 2015 20:10

Thanks Adam,
I spent time through several posts and it seems you are right.
Hopefully is something that can be fixed in future releases and not an intrinsic limitation.

Posted by galbip at Jan 04, 2015 22:38

Hi,

Browsing on Internet I've found someone experiencing the same issue:

http://stackoverflow.com/questions/12708890/youtube-video-not-playing-in-webview-android

and getting a solution using setWebChromeClient method of WebView class:

wv.setWebChromeClient(new WebChromeClient() {
});

From WebView Documantetion:
In order to support inline HTML5 video in your application, you need to have hardware acceleration turned on, and set a WebChromeClient. For full screen support, implementations of onShowCustomView(View, WebChromeClient.CustomViewCallback) and onHideCustomView() are required, getVideoLoadingProgressView() is optional.

Was wondering if this could fix the issue in Android Console.

Thank you

Posted by galbip at Jan 15, 2015 22:10
Document generated by Confluence on Jun 05, 2016 09:39