This page last changed on Dec 26, 2015 by nitzank.

Hi.
I am using openremote for the last 3 mounts and it is a great tool!! I have some problems in viewing my design in a web browser.
my design contain several transparent PNG's and a web view to display RTSP from a IP camera ( using quicktime plugin ).
in Designer the WebView is pointing to : 127.0.0.1:8080/controller/stairs_cam.html file:

<!DOCTYPE html>
<HEAD>
<title>HOME VIEW</title>
<META http-equiv="content-type" content="text/html; charset=utf-8">
</HEAD>
<BODY id="gbody" bgColor="transparent">
<div id="PlayerDiv" style='visibility:visible;position:absolute;top:0px;left:0px;width:627px;height:430px;'>
<OBJECT
CLASSID="clsid:02BF25D5-8C17-4B23-BC80-D3488ABDDC6B"
WIDTH="627"
HEIGHT="430"
CODEBASE="http://www.apple.com/qtactivex/qtplugin.cab"
ID="IEqtpPlayer">
<PARAM NAME="src" VALUE="t.jpg" >
<PARAM NAME="QTSRC" VALUE="rtsp://10.0.0.28:554/user=admin&password=&channel=1&stream=0.sdp?real_stream--rtp-caching=100" >
<PARAM NAME="TYPE" VALUE="application/x-rtsp">
<PARAM NAME="AutoPlay" VALUE="true" >
<PARAM NAME="SCALE" VALUE="ToFit" >
<PARAM NAME="KIOSKMODE" VALUE="True" >
<PARAM name="CONTROLLER" VALUE = "false" >
<PARAM NAME="QTSRCCHOKESPEED" VALUE="movierate" >
<embed width="627"
height="430"
type="application/x-rtsp"
id="FFqtPlayer"
QTSRCCHOKESPEED="movierate"
ENABLEJAVASCRIPT="true"
scale="tofit"
controller="false"
kioskmode="true"
autoplay="true"
qtsrc="rtsp://10.0.0.28:554/user=admin&password=&channel=1&stream=0.sdp?real_stream--rtp-caching=100"
src="t.jpg" >
</embed>
</OBJECT>
</div>
</BODY>
</HTML>

1. the file as a stand alone opens well in IE and Firefox, and I can see the video stream from my camera.
2. in IE web console, the video stream works fine but the transparent PNG's appears as a gray background
3. In Firefox the transparent PNG's appears well but I can't see the video stream ( despite the fact that video is ok in Firefox when I am opening the file directly in Firefox web browser).

I want the ability to have both transparent PNG and RTSP video stream working in web console.
please advise

Document generated by Confluence on Jun 05, 2016 09:34