This page last changed on Feb 11, 2015 by pierre2302.

I installed the controller OpenRemote Version 2.1.0 of 20.01.2015, but I have a problem with the webconsole which is still 2.0 instead of 2.1.2.

If someone has a solution please

Thank you


webcons.jpg (image/jpeg)

You can download 2.1.2 from http://sourceforge.net/projects/openremote/files/For%20Developers/WebConsole%20%28Developer%20Releases%29/ and replace the webconsole.war in your controller's /webapps directory

Posted by juha at Feb 11, 2015 05:35

Thank you very much, I try it in the day

Posted by pierre2302 at Feb 11, 2015 05:49

I tried replacing the webconsole.war file with the one on the download link above, it still appears OpenRemote webconsole 2.0 Build 8914.

So I do not know actually if you have not forgotten to change the value of version may be in the index

Posted by pierre2302 at Feb 11, 2015 06:46

Try a Ctrl+Shift+R to force a reload of any cached files.

Posted by kurrazyman at Feb 12, 2015 11:59

Version 2.0 also.

Controller 2.1.0 20.01.15. In FF and GoogleChrome, after complete cleaning browsers.

Posted by aleksey_z at Feb 12, 2015 12:45

Hi,

The Web Console 2.0 is a little misleading at the top of the toolbar (this should be changed); it referred to the fact that it was a complete replacement of the original web console that existed many years ago. The build number at the bottom of the toolbar is the important part and that is populated at build time based on the revision of the last commit within the branch being compiled.

Web console is versioned separately from the controller.

If you are seeing the same build number in different versions of the web console then this can only mean one of two things: -

-The versions (although labelled differently are actually the same)
-The ANT build task which gets the last commit revision was not working correctly when the WAR files were generated

I have checked the project tags for the web console and this is what should be: -

Web Console 2.1.0 - r7746
Web Console 2.1.2 - r8914
Web Console 2.1.2 (for Pro Controller 1.0.10) - r8961
Web Console 2.1.3 (I don't see a compiled WAR of this available in the downloads) - r9683

@Pierre can you please explain what the issue is you're experiencing.

Posted by kurrazyman at Feb 12, 2015 16:00

Thank you for your help

The problem I have is the same as @Aleksey after emptying the cache I always consoled OpenRemote web 2.0 that appears.

But as you specify in your comment I build 8914 version 2.1.2 that match.

So I think I'm well 2.1.2 but do not rely on what there is written at the top of the green square

Sorry for my english

Posted by pierre2302 at Feb 12, 2015 20:54

I See in downloads new release OR 2.1.1, and WebConsole 2.1.3.
Can I update WebConsole?

Posted by aleksey_z at Feb 15, 2015 12:18

I tried the webconsole 2.1.3 is functional build 9683 appears

As against a shame we can not always interact with the web view

Posted by pierre2302 at Feb 15, 2015 22:31

Apparently the webview are interractives with the touch (tactile), but not with the mouse !!

Posted by pierre2302 at Feb 26, 2015 19:30

I've updated the OR 2.1.1 and the WebConsole 2.1.3. Noted the following, with WebView charts output (EmonCMS). Everything works on Android, iOS devices; but in the browser (GoogleChrome, FF) I can not control charts, using the mouse (switch: day, week, month, year, etc.).

Posted by aleksey_z at Feb 27, 2015 08:44

I manage to control emoncms, but needs to have a touch-sensitive screen it's a pity that for the mouse that is not planned !!

Posted by pierre2302 at Apr 11, 2015 03:15

In revision 100050 (JIRA WEBCONSOLE-86) the web view within the web console was made interactive (i.e. mouse events were passed through). Webconsole 2.1.3 was created before this. I will make a build and put it on dropbox and provide a link here.

Posted by kurrazyman at Apr 12, 2015 11:06

Richard Turner thank you very much

I take the opportunity at any chance I have another small problem with webconsole page when I change my panel and I return to the previous page, I have lots of little OpenRemote icon that appears. Maybe you have a solution

Posted by pierre2302 at Apr 12, 2015 15:48

Hello

I would want to know if the new webconsole version has was published ?

thank you

Posted by pierre2302 at Jul 20, 2015 21:19
Document generated by Confluence on Jun 05, 2016 09:39