This page last changed on Sep 17, 2014 by tommi.

Hi
i was running OR using 1wire for some time and finally I decide to use z-wave devices.
I have AEON Z-stick and brand new instalation of OR on Synology ds213
i have made all steps described in the manual: http://www.openremote.org/display/docs/OpenRemote+2.0+How+To+-+Synology+with+Z-Wave
the same version of OR, ARM drivers downloaded, device recognized.

having no access to lock i had error like:
check_group_uucp(): error testing lock file creation Error details:Permission denied check_lock_status: No permission to create lock file.
please see: How can I use Lock Files with rxtx? in INSTALL

changed permissions is better but still not ok :/
device is recognized under ttyUSB2, the only difference is that I use mapping to /dev/usb/ and not directly to /dev/ BUT owfs and scripts can run without issues on them without any issues.

T: Bus=02 Lev=03 Prnt=03 Port=02 Cnt=02 Dev#= 7 Spd=12 MxCh= 0
D: Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=10c4 ProdID=ea60 Rev= 1.00
S: Manufacturer=Silicon Labs
S: Product=CP2102 USB to UART Bridge Controller
S: SerialNumber=0001
C:* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=100mA
I:* If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=00 Prot=00 Driver=cp210x
E: Ad=81(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms
E: Ad=01(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms

in controller.xml it is set as /dev/usb/ttyUSB2

catalina trows error:

WARNING: RXTX Version mismatch
Jar version = RXTX-2.2pre1
native lib Version = RXTX-2.1-7
gnu.io.NoSuchPortException
at gnu.io.CommPortIdentifier.getPortIdentifier(CommPortIdentifier.java:269)
at org.openremote.controller.protocol.zwave.ZWaveGatewayRxtx$ZWaveConnectionThread.run(ZWaveGatewayRxtx.java:108)
ERROR 2014-09-17 11:01:33,347 : Could not load commandBuilder class: org.openremote.controller.protocol.vera.VeraCommandBuilder
java.lang.ClassNotFoundException: org.openremote.controller.protocol.vera.VeraCommandBuilder

and log z-wave.log remain empty.
any clue what to check more?


Untitled1.png (image/png)

What do you mean with "mapping to /dev/usb"? Do you have a symlink?
Try with the regular location /dev/ttyUSB2 and see of that works.

Posted by mredeker at Sep 18, 2014 00:10

Based on some manuals there was command to make nodes on /dev/usb folder, now it is in standard place.
ttyUSB0 (one wire) and ttyUSB1 (relay board) works fine,
on ttyUSB2 I have z-wave stick. it is recognized correctly by synology.
on catalina.log there is problem with make a lock (all permissions like on manual) and zwave.log is still empty.

Posted by tommi at Sep 21, 2014 10:47

You've added the user 'openremote' to the groups 'dialout' and 'uucp'. The 'dialout' group has no write permission to /dev/ttyUSB0 and the 'uucp' group has no write permission to the folder /var/lock. At first glance, it seems that these permissions are missing.

Posted by rhitz at Sep 22, 2014 07:53

Yes.... done and log is here.... thanks.

Posted by tommi at Sep 22, 2014 08:14
Document generated by Confluence on Jun 05, 2016 09:39